Top / PECL / pdo / install


 #setlinebreak(on)
 * PDOのインストール [#ab01d5cb]
 
 [[PECL::PDO(PHP Data Objects)がアツイ!!>PECL/pdo]]
 [[PECL::PDOのインストール>PECL/pdo/install]]
 [[PECL::PDOのドライバーインストール>PECL/pdo/driver]]
 
 #htmlinsert(googleAdsense.html)
 #ref(http://dozo.rgr.jp/img/img52_pecl.gif,right,nolink,around,PHP::PECL)
 
 まずはインストールから。
 PHP4を使用している人は残念ながら対象外。
 PDOの利用条件はPHP5以上。
 
 ** PHP5でのインストール(DSO) [#p7d6ad5e]
  # pecl install pdo
 と入力すると勝手にコンパイルを始めてくれる。
 するとextensionディレクトリに
  pdo.so
 というファイルが出来てるので
 php.iniに
  extension=pdo.so
 と記入する
 または
  dl( pdo.so );
 とプログラムに記述すると使用できる。
 
 ** PHP5でのインストール(コンパイル) [#lc53bcb9]
 特別利点はないが、
 自分でコンパイルしたい場合は、
 ファイルをダウンロードしてきてphpizeをうち、
 インストールをする。
  $ pecl download pdo
  $ tar xvfz PDO.x.x.x.tgz
  $ cd PDO.x.x.x
  $ phpize
  $ ./configure 
  $ make
  # make install
 
 ** PHP5でのインストール(静的、スタティック) [#j61b8877]
 静的に導入したい場合は、
 既存のextensionとダウンロードしたものを入れ替えて、
 PHP5をコンパイルする
  $ wget php-5.x.x.tar.gz
  $ tar xvfz php-5.x.x.tar.gz
  $ rm -Rf php-5.x.x/ext/pdo
  $ pecl download pdo
  $ tar xvfz PDO.x.x.x.tgz
  $ mv PDO.x.x.x php-5.x.x/ext/pdo
  $ cd php-5.x.x
  $ ./buildconf
  $ ./configure --with-pdo 〜〜〜
  $ make
  # make install
 
 ** PHP5.1でのインストール(静的、スタティック) [#f224e21d]
 PHP5.1を使っている人は標準でバンドルされている。
 普通にコンパイルをするとインストールは完了している
 また、最新版を利用したい場合は、
 PHP5のバンドルインストールと同じ事をする
 
 ** PHP5.1でのインストール(DSO) [#ad5b715b]
 どうしてもDSOでインストールしたい場合は、
 PHP5.1をコンパイルするときに一端PDOを無効にし、
 peclコマンドでインストールする
  $ wget php-5.x.x.tar.gz
  $ tar xvfz php-5.x.x.tar.gz
  $ cd php-5.x.x
  $ ./configure --disable-pdo 〜〜〜
  $ make
  # make install
  # pecl install pdo
 
 
 #htmlinsert(googleAdsense.html)
 
 [[PECL::PDO(PHP Data Objects)がアツイ!!>PECL/pdo]]
 [[PECL::PDOのインストール>PECL/pdo/install]]
 [[PECL::PDOのドライバーインストール>PECL/pdo/driver]]
 
 
 
 #comment


トップ   編集 差分 バックアップ 添付 複製 名前変更 リロード   新規 一覧 単語検索 最終更新   ヘルプ   最終更新のRSS
Third Project
証券会社ランキング比較